自动实现php4和php5环境的切换……

因为php4早就end了,所以是有必要切换到php5的了,所以有时调试需要整合一下了

在WIN98下以apache模块方式安装php手记 foolboy@chinaren.com ★相关软件:
mod_php4-4.0.1-pl2.zip php-4.0.1pl2-Win32.zip
以上软件可以在www.php.net或者www.phpuser.com上下载
注意两者的版本一定要一样,
(关键是mod_php4.dll与php4ts.dll及Msvcrt.dll版本相同) ★具体步骤:
用winzip分别将两个.zip文件解压 php-4.0.1pl2-Win32.zip解压至
E:澳门新葡萄京官网首页,php目路中 mod_php4-4.0.1-pl2.zip解压至 E:mod_php目录中
安装php解释器,将php.ini-dist拷贝至%WINDOWS%即windows
的安装目录下,重命名为php.ini.用编辑器编辑php.ini 改动如下: extensiondir
= E:Phptoolsphp ;动态加载库所在目录 在Atuoexec.bat中增加 SET
PASS=E:phptoolsphp ;
或者直接将php4ts.dll拷贝至%SYSTEM%中给Apache添加模块,
将E:mod_phpapache_dirmodules下的mod_php4.dll拷贝至
Apache安装目录下的.modules子目录中; 将Msvcrt.dll
拷贝至Apache安装的根目录下; 将
E:mod_phpapache_dirconfmod_php4.conf拷贝至Apache的
.conf子目录中; 然后编辑Apache的.conf下的srm.conf 在其中添加一条:
Include conf/mod_php4.conf; ★最后测试 执行 apache -k start
进行启动,看到出现 Apache/1.3.14 PHP/4.0.1pl2 running…
可以知道你的php已经以Apache模块方式运行了, 如果还不确定就
写一个test.php测试吧. test.php phpinfo() ?>
注:本次使用的Apache版本是1.3.14

做了一个脚本,让他们批处理一下就能自动切换了,方便的说

环境:

window XP SP2 +apache2.2.6 + PHP4.4.7 +PHP5.2.5

PHP4目录:E:webphp4

PHP5目录:E:webphp5

APACHE目录:E:webApache2.2

1.需要两个apache的文件,,因为apache2.2.6对php4.47支持不好,所以要另外加插件了.(参考:)

php4的为:_php4.conf

PHP5为:_php5.conf

  1. 准备两个批处理文件就可以了

变成php4:

copyphp.inic:windowscopyphp4ts.dllc:windowscopyphp4ts.libc:windowscopyE:webApache2.2conf_php4.confE:webApache2.2conf

变成php5

delc:windowsphp.inidelc:windowsphp4ts.dlldelc:windowsphp4ts.libcopyE:webApache2.2conf_php5.confE:webApache2.2conf

当然以上目录都是放在php4根目录下的,你只要根据目录修改就可以了

发表评论

电子邮件地址不会被公开。 必填项已用*标注